Home > The Specified > Visual Studio Cannot Add The Specified Assembly To The Global Assembly Cache

Visual Studio Cannot Add The Specified Assembly To The Global Assembly Cache

Contents

I did an iisreset, I almost downloaded sysinternals, I stopped the timer service in services… finally, I just closed and reopened visual studio itself and I was finally able to close Thus, I have turned to the internet and I'm hoping someone out there might know why this happening and how we can prevent it in the future. Enter your search term here... The logs are frustratingly unhelpful with only two lines: Solution Deployment : Error Global Deployment failed for CustomSolution.Common.wsp.

Uninstall CopyMove 2013 using the Uninstall.cmd script. Bookmark the permalink. ← Notify FAIL Activate On Default → 13 Responses to Error: Cannot add the specified assembly to the global assemblycache Brage R Tukkensæter (@brager) says: 2011-08-07 at 01:02 What's the purpose of the same page tool? Home About Paul Paul Galvin's SharePoint SpaceCommentsPosts Tools Popular postsTell me about your blog! (27)Display Content Query Web Part Results in a Grid / Table (22)Create Bar Graphs https://social.msdn.microsoft.com/Forums/office/en-US/851fbc5f-ce92-4bf4-9ca3-e7aa59be299f/sharepoint-2013-deployment-error-cannot-add-the-specified-assembly-to-the-global-assembly-cache?forum=sharepointdevelopment

Visual Studio Cannot Add The Specified Assembly To The Global Assembly Cache

Try to deploy this solution using PowerShell; 3. This ensure the latest code will be used.) If you do receive the error. Collatz Conjecture (3n+1) variant Arguments of \newcommand as variable names?

Always use upgrade. You can do a Find for the DLL file from the top menu bar to identify the process which it's using. Restart the Windows SharePoint Services Administration Service4. Add-spsolution Temporarily disable all of the DocRead timer jobs from within Central Admin.

Why are "The Thanksgiving House" and "Legally Tender" (both movies) the same movie? Gacutil Using GACUtil I was able to get some more information and it deploys fine now. Verify that the solution packages sharepointproducts_platform2013.wsp and sharepointproducts_copymove2013.wsp have been retracted and removed from the farm. using FUSLOGVW.exe to check for log entries during deploy, but it only seems to log on assembly binding and not GACing.

We started by created a test solution package and deployed it on the environment which worked fine to identify whether the issue was with the Package or environment. Process Explorer Join them; it only takes a minute: Sign up Here's how it works: Anybody can ask a question Anybody can answer The best answers are voted up and rise to the IIS restarts did not make a difference. Recreating the keyfile solved the issue. –Thomas Nov 22 at 9:04 add a comment| Your Answer draft saved draft discarded Sign up or log in Sign up using Google Sign

Gacutil

HomeProductsSupportRelationsNewsAbout Copyright © 2009-2015 SharePoint Products Nothing But Technology!!!! http://sharepoint.stackexchange.com/questions/46286/cannot-add-the-specified-assembly-microsoft-practices-servicelocation-dll The problem was resolved by using GACUtil and uncovering that my project keyfile was somehow corrupt. Visual Studio Cannot Add The Specified Assembly To The Global Assembly Cache Help Us Improve This Article What did you think of this article? Gacutil Location Exception message - Error: Cannot add the specified assembly to the global assembly cache: CustomSolution.Common.dll.

How about creating and deploying a simple solution, will this error occur? 4. Send to Email Address Your Name Your Email Address Cancel Post was not sent - check your email addresses! The dll is not present in the GAC_MSIL folder nor assembly or assembly\temp (see point 3). Why shouldn’t I use Unicode characters to simulate typographic styles (such as small caps or script)? Gacutil Download

Reply Brandon says: 2013-02-11 at 16:48 The iisreset was the solution for me too! It'll help other users who are visiting your thread for the similar problem. In my case, I was not allowed to uninstall it because it was in use, so with some help from the process explorer from Sysinternals I found (click Ctrl+F and search) I'm using Add-SPSolution and Install-SPSolution to deploy the wsp.

So, we have decided to tackle this issue and clearly failed. The thing is it works "sometimes" and for the life of me I can't figure out why. This error occurs because one or more of the DocRead assemblies are in being used.

A documentation from TechNet about Deploy solution packages for your reference: http://technet.microsoft.com/en-us/library/cc262995(v=office.14).aspx Best regardsPatrick Liang TechNet Community Support

Marked as answer by Dennis GuoMicrosoft contingent staff, Moderator Sunday, January

Will Minecraft map items automatically update with terrain changes? Your help is indeed valued.ReplyDeleteRobel25 April 2016 at 23:49Thank you for your post.ReplyDeleteRobert Flemmener18 May 2016 at 07:51It didn't help Us.IISRESET + reset SPTIMERV4 + physical restart + SysInternals Handle to This happened because you have already the same dll file installed and our solution is trying to add newer version of the same dll. Related Articles Home Solutions Forums Cookie policy We use cookies to try and give you a better experience in Freshdesk.

But now our project is getting big and deployment take a long time and it is becoming incredibly annoying having to deploy twice. Edit: Thanks to pholpar for providing a way to get additional diagnostics information! Reply Øystein Garnes says: 2011-08-07 at 18:13 Hi Brage, thanks for the tip! Radu Reply Pål says: 2012-05-04 at 11:26 Thanks!

Reply Rich says: 2013-08-30 at 19:55 rebooting worked… and allowed me to get a coffee Reply FK says: 2013-11-04 at 14:14 The iisreset was the solution for me too! Code Coverage Calculation - Seems to be including code in test methods I feel like my encounters are too easy, even using the encounter tables Why does rotation occur? Ignore any error messages. All-Knowing Being is Lonely How smart is the original Ridley Scott Xenomorph really?

Please check that whether the account you used is both a local administrator on the server and an administrator within the SharePoint farm; 2. it worked like a charm🙂 Reply Pradeep Sharma says: 2012-11-28 at 16:47 Thanks Øystein Garnes… It worked…. Can't use the "at" utility What is the importance of Bézout's identity? Yes NoSend feedback Sorry we couldn't be helpful.

As the error message did not tell me why this happened or how I could fix it, I asked google. Will definitely be using that tool more in the future. Growing Awareness / Adoption of JavaScript Frameworks Spinning SharePoint Timer Jobs from Site Collection Configuration Weekly Roundup – SharePoint, RWD, Meta Stuff & Harley Blog Series on Continuous Integration with SharePoint Rebooted and deleted DLLs in Temp.

We get around this by restarting IIS and once we do the project will deploy fine. uninstalling manually from gac helped me (had to do a iisreset to unlock the file first) Reply Simi says: 2012-05-09 at 14:00 Try doing an IISreset , clear your Temporary Files